Can't Get donations to work.....

This is the place where you can find everything related to the dedicated server, control scripts and community tools.

Moderators: Pit Crew, TM-Patrol

Post Reply
TheCrow
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 10 Aug 2009 23:31
Owned TM-games: TMUF

Can't Get donations to work.....

Post by TheCrow » 12 Jul 2010 00:59

Im struggling getting donations to work on ym server, i have followed the instructions on the dedicated server thread, and searched all over but to no avail.

My server is a basic stadium server that i rent, and the game version i own is Track Mania United Forever.

I can go to the player page located here..http://official.trackmania.com/tmf-playerpage/main.php,
and I have set up a dedicated server login.

I then proceeded to send my server login through my main game account, it says login recognised and the coppers send ok.
I have the set up my dedicated_cfg.txt with the appropriate details like so...

Code: Select all

<dedicated>
	<authorization_levels>
		<level>
			<name>SuperAdmin</name>
			<password>********</password>
		</level>
		<level>
			<name>Admin</name>
			<password>*******</password>
		</level>
		<level>
			<name>User</name>
			<password>User</password>
		</level>
	</authorization_levels>

	<masterserver_account>
      		 <login>lapspg</login>
      		 <password>*****</password>
      		 <validation_key>***</validation_key>
   		 </masterserver_account>
	
	<server_options>
I presume I have put the <masterserver_account> details in the right place, on the server file they were emitted, but i downloaded a copy of the dedi server for reference and copied where it was located in the file there. Above where there are ***'s is where I have deleted passwords for security, etc. And I can confirm my validation key is the last 3 charachters of my player key also.

My problem is that I still cannot donate any more coppers to my server account. It simply says Error you do not have enough coppers, yet i have a few thousand, but cannot donate any?

I'm really struggling to see where im going wrong as i've followed the instructions to the letter.

I started a fresh and deleted the dedicated server account on my player page, which gave my main account all it's coppers back. So the server account creation works, and it recieves coppers, however my server does not seem to communicate with it?

Any advice anyone can offer would be greatly appreciated.

I've attatched a copy of my dedicated_cfg in case its needed.

Thanks in advance! I've been trying for hours and cant figure it out for the life of me!

TheCrow
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 10 Aug 2009 23:31
Owned TM-games: TMUF

Re: Can't Get donations to work.....

Post by TheCrow » 12 Jul 2010 00:59

The forum wouldn't allow me to upload a copy of my config so here it is instead....

Code: Select all

<?xml version="1.0" encoding="utf-8" ?>

<dedicated>
	<authorization_levels>
		<level>
			<name>SuperAdmin</name>
			<password>********</password>
		</level>
		<level>
			<name>Admin</name>
			<password>*********</password>
		</level>
		<level>
			<name>User</name>
			<password>User</password>
		</level>
	</authorization_levels>

	<masterserver_account>
      		 <login>lapspg</login>
      		 <password>*******</password>
      		 <validation_key>***</validation_key>
   		 </masterserver_account>
	
	<server_options>
		<name>$s$w$i$000::$00fpG$000:: $fffLaps</name>
		<comment>Welcome to $000::$00fpG$000::$fffLaps $z$ihosted by $l[http://www.phantom-gaming.com]$O$S$0FFPhantom-Gaming.com</comment>
		<hide_server>0</hide_server>					<!-- value is 0 (always shown), 1 (always hidden), 2 (hidden from nations) -->

		<max_players>16</max_players>
		<password></password>
		
		<max_spectators>8</max_spectators>
		<password_spectator></password_spectator>
		
		<ladder_mode>forced</ladder_mode>				<!-- value between 'inactive', 'forced' (or '0', '1') -->
		<ladder_serverlimit_min>0</ladder_serverlimit_min>		<!-- Those values will be clamped to the limits authorized on http://official.trackmania.com/tmf-ladderserver/ -->
		<ladder_serverlimit_max>50000</ladder_serverlimit_max>		

		<enable_p2p_upload>True</enable_p2p_upload>
		<enable_p2p_download>True</enable_p2p_download>
		
		<callvote_timeout>60000</callvote_timeout>
		<callvote_ratio>0.5</callvote_ratio>				<!-- default ratio. value in [0..1], or -1 to forbid. -->
		<callvote_ratios>
			<voteratio command="Ban" ratio="0.65"/>
			<!-- commands can be "Ban", "Kick", "ChallengeRestart", "NextChallenge", ... -->
		</callvote_ratios>

		<allow_challenge_download>False</allow_challenge_download>
		<autosave_replays>False</autosave_replays>
		<autosave_validation_replays>False</autosave_validation_replays>

		<referee_password></referee_password>
		<referee_validation_mode>0</referee_validation_mode>		<!-- value is 0 (only validate top3 players),  1 (validate all players) -->

		<use_changing_validation_seed>False</use_changing_validation_seed>


		 
	</server_options>
	
	<system_config>

<disable_coherence_checks>laps</disable_coherence_checks> 
    <!-- values: false (default) , laps (disable the check only for laps races), true (disable all the checks) --> 
		<connection_uploadrate>512</connection_uploadrate>		<!-- Kbps (kilo bits per second) -->
		<connection_downloadrate>8192</connection_downloadrate>		<!-- Kbps -->

		<force_ip_address>91.204.208.26</force_ip_address>
		<server_port>2370</server_port>
		<server_p2p_port>3470</server_p2p_port>
		<client_port>0</client_port>
		<bind_ip_address>91.204.208.26</bind_ip_address>
		<use_nat_upnp></use_nat_upnp>
		
		<p2p_cache_size>600</p2p_cache_size>

		<xmlrpc_port>5020</xmlrpc_port>
		<xmlrpc_allowremote>True</xmlrpc_allowremote>			<!-- If you specify an ip adress here, it'll be the only accepted adress. this will improve security. -->
		
		<blacklist_url></blacklist_url>
		<guestlist_filename></guestlist_filename>
		<blacklist_filename></blacklist_filename>
		
		<packmask>stadium</packmask>

		<allow_spectator_relays>False</allow_spectator_relays>

		<!-- <minimum_client_build>2009-10-01</minimum_client_build> -->

		<use_proxy>False</use_proxy>
		<proxy_login></proxy_login>
		<proxy_password></proxy_password>
	</system_config>
</dedicated>

User avatar
maau
road tourist
road tourist
Posts: 101
Joined: 12 Apr 2009 18:36
Owned TM-games: Finally I've TMUF ^^

Re: Can't Get donations to work.....

Post by maau » 12 Jul 2010 01:32

Naturally, it isn't a matter of configs. Try sending a few coppers to your server account through the in-game mail.

It happened to me, and that fixed it.
Image

Image

TheCrow
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 10 Aug 2009 23:31
Owned TM-games: TMUF

Re: Can't Get donations to work.....

Post by TheCrow » 12 Jul 2010 16:03

Thats the problem, i've sent thousands and still the damn thing wont work?

User avatar
maau
road tourist
road tourist
Posts: 101
Joined: 12 Apr 2009 18:36
Owned TM-games: Finally I've TMUF ^^

Re: Can't Get donations to work.....

Post by maau » 12 Jul 2010 16:09

It's weird, config seems to be fine. Have you tried a lottery to see if the problem is the donations or the coppers in general ?

If it's a problem with coppers in very situation, check you put fine the validation key.

Or wait to a more experienced user to answer. (I've never had a problem with coppers)
Image

Image

TheCrow
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 10 Aug 2009 23:31
Owned TM-games: TMUF

Re: Can't Get donations to work.....

Post by TheCrow » 12 Jul 2010 16:38

Sorted!

Damn server host had overwritten the masteraccount settings, so whatever i put it ignored it!

All fixed now tho, i wish they would tell u these things before u waste days trying to fix it!

Post Reply