Dedicated Server doesn't work...

This is the place where you can find everything related to the dedicated server, control scripts and community tools.

Moderators: Pit Crew, TM-Patrol

grifoli
cyclist
cyclist
Posts: 45
Joined: 25 Mar 2010 05:12
Owned TM-games: TMN

Dedicated Server doesn't work...

Post by grifoli » 08 Apr 2010 23:39

Hi guys, I know there are many topics about dedicated server, but mine just doesn't want to work (People on the internet cannot join it, they get the "Could not contact the server" error).

I'm hosting the dedicated server for Trackmania Nations ESWC on the computer I'm using to play the game.

I configured my computer so it gets a static IP address.

Image

I also changed the port 2350 for 2352, 3450 for 3452, and 5000 for 5002 in the dedicated.cfg file.

Image

Then, I forwarded those ports on my routeur

Image

Then, I started the server. But I'm still getting this warning: "You seem to be on a private network. Unless you've configured your NAT, the other players on internet will not be able to join in...".

I know it's just a warning, but I asked a friend of mine to join the server, but he got the 10060 error.

What am I doing wrong? Did I forget something? I doubled check the DNS addresses, and they are correct.

Any help would be appreciated! Thank you.

EDIT: I've installed the Microsoft Loopback adapter and I've activated it. Now, the warning doesn't appear anymore when I start the server, but my friends are still getting the 10060 error.

Paris69
speedy pilot
speedy pilot
Posts: 381
Joined: 05 Apr 2006 20:50

Re: Dedicated Server doesn't work...

Post by Paris69 » 09 Apr 2010 10:22

u have to force your public IP, not 192.168....

User avatar
Ant
TM-Patrol
TM-Patrol
Posts: 1845
Joined: 01 Dec 2007 17:04
Owned TM-games: TMN, TMUF, TM Wii
Location: London, England
Contact:

Re: Dedicated Server doesn't work...

Post by Ant » 09 Apr 2010 10:38

Paris69 wrote:u have to force your public IP, not 192.168....
I think he must be running this from his home pc, so those port forwards should be fine, as thats how I had mine setup on my home PC when I used to run it from there.

The static IP set for the PC is also good, as the router will just give this PC the same (internal) address each time it connects, and will show its external IP to all as it should.

Now for the actual problem, I notice you have the xmlrpc port as 5002, but this has not been forwarded - try that too and see if it works. If it doesn't, then we can go into more detail at that point :thumbsup:

grifoli
cyclist
cyclist
Posts: 45
Joined: 25 Mar 2010 05:12
Owned TM-games: TMN

Re: Dedicated Server doesn't work...

Post by grifoli » 09 Apr 2010 12:49

Thanks for the replies guys. I read that it wasn't necessary to forward the port 5002 unless if I want to remotely control the server, but I gave it a try anyway.

Image

Still not working, my friends can't join the server :(

I have to tell you that the server had been working for 2 weeks before that happened ! Is it possible that I've been hacked ?

I look forward to get a solution..!

Paris69
speedy pilot
speedy pilot
Posts: 381
Joined: 05 Apr 2006 20:50

Re: Dedicated Server doesn't work...

Post by Paris69 » 09 Apr 2010 12:50

XXX-Ant wrote:and will show its external IP to all as it should.
no, the server will bind the 192.168.1.15 in server listing - he must set the external IP in <force_ip_address>, thats the way.

(the 5002 port must be not forwarded (if the xaseco is on the same machine), the basic port is 2352.)

Paris69
speedy pilot
speedy pilot
Posts: 381
Joined: 05 Apr 2006 20:50

Re: Dedicated Server doesn't work...

Post by Paris69 » 09 Apr 2010 12:51

grifoli wrote:I look forward to get a solution..!
set the external IP in <force_ip_address>

grifoli
cyclist
cyclist
Posts: 45
Joined: 25 Mar 2010 05:12
Owned TM-games: TMN

Re: Dedicated Server doesn't work...

Post by grifoli » 09 Apr 2010 12:53

Paris69 wrote:
XXX-Ant wrote:and will show its external IP to all as it should.
no, the server will bind the 192.168.1.15 in server listing - he must set the external IP in <force_ip_address>, thats the way.

(the 5002 port must be not forwarded (if the xaseco is on the same machine), the basic port is 2352.)
Oh ok I'll put my external ip address in <force_ip_address> and tell my friend to join the server again. I'll give you a feedback in couple of minutes.

User avatar
Ant
TM-Patrol
TM-Patrol
Posts: 1845
Joined: 01 Dec 2007 17:04
Owned TM-games: TMN, TMUF, TM Wii
Location: London, England
Contact:

Re: Dedicated Server doesn't work...

Post by Ant » 09 Apr 2010 12:56

Fair enough then paris, I was just quoting how I had mine setup when I ran it from my home PC.

To be fair, my online server is running strangely too at the moment, and it has always been fine - maybe theres something going on with the master server ??

grifoli
cyclist
cyclist
Posts: 45
Joined: 25 Mar 2010 05:12
Owned TM-games: TMN

Re: Dedicated Server doesn't work...

Post by grifoli » 09 Apr 2010 13:03

I've just put my external ip address in <force_ip_address>, but still no luck, my friend is gettins the error 10060.

Image

Is there something to do with Microsoft Loopback Adapter ? Should I turned if off ?

User avatar
Ant
TM-Patrol
TM-Patrol
Posts: 1845
Joined: 01 Dec 2007 17:04
Owned TM-games: TMN, TMUF, TM Wii
Location: London, England
Contact:

Re: Dedicated Server doesn't work...

Post by Ant » 09 Apr 2010 13:13

What about the server controller config ? For example, in XAseco's config, at the bottom there is this section :

Code: Select all

<tmserver>
    <login>SuperAdmin</login>
    <password>YOUR_PASSWORD</password>
    <ip>127.0.0.1</ip>
    <port>5002</port>
  </tmserver>
</settings>
This is how yours should look, obviously you need your password (same as in dedicated config)

EDIT--> The microsoft loopback adapter really isn't needed, I used it before just to get rid of the warning, but I have since found out that enabling it could be a security hole.

EDIT--> Also in the dedicated config, if you use the above in the XAseco config, do your authorization levels look like this ?

Code: Select all

<authorization_levels>
		<level>
			<name>SuperAdmin</name>
			<password>YOUR_PASSWORD</password>
		</level>
		<level>
			<name>Admin</name>
			<password>PASSWORD</password>
		</level>
		<level>
			<name>User</name>
			<password>PASSWORD</password>
		</level>
	</authorization_levels>
EDIT--> To be fair, if your server was running fine for 2 weeks before this, I'm sure you have these settings correctly. But its worth it just to check.
Last edited by Ant on 09 Apr 2010 13:34, edited 4 times in total.

Paris69
speedy pilot
speedy pilot
Posts: 381
Joined: 05 Apr 2006 20:50

Re: Dedicated Server doesn't work...

Post by Paris69 » 09 Apr 2010 13:14

for me is your ip address (24.200.....) dead. are you sure with it? (and it is a public ip address?)

User avatar
Ant
TM-Patrol
TM-Patrol
Posts: 1845
Joined: 01 Dec 2007 17:04
Owned TM-games: TMN, TMUF, TM Wii
Location: London, England
Contact:

Re: Dedicated Server doesn't work...

Post by Ant » 09 Apr 2010 13:19

oh yeah, you could have an IP that changes every so often - have you checked that ?

Also, this site will check if your server is reachable http://dedimania.net/deditest/ and will also automatically show you your external ip.

Try that and see what you get, I just tried using the settings you posted here, but it could not be reached, but as the script says, that could be down to xmlrpcallowremote being set as false, or firewall issues.

grifoli
cyclist
cyclist
Posts: 45
Joined: 25 Mar 2010 05:12
Owned TM-games: TMN

Re: Dedicated Server doesn't work...

Post by grifoli » 09 Apr 2010 13:55

Ooook it goes bad to worst. I unplugued my routeur, and I pluged my modem directly into my computer. I changed the settings of my internet connection, so now I get IP address automatically. Now I got a new IP address ( 70.82.162.8 ). I typed it in <force_ip_address>, and I started the server again.

But my friend still can't join it. I've used the deditest website, and I've tried to reach the server with that ip address, no respond.

So now, I know that the problem isn't my routeur, since it is unplugued.. What else could it be?

XXX-Ant -> I've already looked at that and my IP address doesn't change usually. But now, it has changed probably because my cpu is plugued directly in my modem. My server config looks like that:

Image

Paris69
speedy pilot
speedy pilot
Posts: 381
Joined: 05 Apr 2006 20:50

Re: Dedicated Server doesn't work...

Post by Paris69 » 09 Apr 2010 14:04

70.82.162.8 is dead

grifoli
cyclist
cyclist
Posts: 45
Joined: 25 Mar 2010 05:12
Owned TM-games: TMN

Re: Dedicated Server doesn't work...

Post by grifoli » 09 Apr 2010 14:07

Paris69 wrote:70.82.162.8 is dead
How can it be dead ??

Image

Image

Post Reply