Page 7 of 8

Re: The big Dedimania discussion

Posted: 10 Sep 2010 11:41
by nicomoore0
Can I increase the dedimania record parameters from 50 to 100 in the XAseco config?

Anni

Re: The big Dedimania discussion

Posted: 10 Sep 2010 12:36
by jamie_macdonald
As far as i know you can only go up to 30 without a donation to dedimania, and you can up it with a discussion and donation to Slig and his Dedimania site...

So yes you can up it to 100, but unless you discuss a deal with slig for greater space it will be useless (i am not sure if it can do more that 60 recs per track but i think it can if you ask nicely / donate generously) :thumbsup:

Re: The big Dedimania discussion

Posted: 15 Sep 2010 19:43
by nicomoore0
what type of donation and how much?

Re: The big Dedimania discussion

Posted: 16 Sep 2010 14:09
by jamie_macdonald
nicomoore0 wrote:what type of donation and how much?
Probably best to ask slig? (or whoever answers the dedimania site contact forms?)

I have never done this myself so i am not 100% on the proccess, best thing is to ask the dedi team the question (if there is a team and not just slig doing it all hehe ..Xymph too maybe? ^^).

GL :thumbsup:

Re: The big Dedimania discussion

Posted: 16 Sep 2010 15:58
by Slig
The increased number of records (for server or for player) still not an official feature, so the price is actually not definitive. I will try to answer you soon.

Increasing the number in xaseco (or fast or other) will not change the stored number of records on dedimania database. The max value has to be changed on dedimania database side. Btw, the max value won't exceed 80 i think (which will already increase a lot the number of records)

Re: The big Dedimania discussion

Posted: 14 Nov 2010 19:31
by Xymph
Here is another housekeeping update. Below are the tools/versions that are now disabled for Dedimania, with bold indicating the changes since the previous list.

ADEDIMANIA: before v0.7 as well as v0.8(a)
ADEDIMANIA: v0.7 on Aseco v2.1.6 & v2.2.1 and v1.0 on Aseco v2.0b, v2.2a & v3.0.0
ASECO/RASP: all v0.xx
ASECO_CALSMURF2: before v2.2.0c
ASECO_CDV: all
ASECO v1.x: all
ASECO oddball: all
ASRM: before v1.75
CAR: all
DeReCo: before v0.6
FAST: before v3.1.3o in the v3.1.x series, all in the v3.2.0 series, all except v3.2.1u in the v3.2.1 series, all except v3.2.2c/w/y/z in the v3.2.2 series, and before v3.2.3g in the v3.2.3 series
FeniX: all
FLASH: v"v0.7" (not v0.7)
NeSCo: all
Onyx: before v3.1.4
RCP: before v4.0.3.5
RCP: unofficial v1.x
SATO: all
TM-DeReCo: all
TMSC: before v1.00
TMSPS: before v0.3
TRUCK: before 9.08.17 in the 9.* series and before 10.08.14 in the 10.* series
XASECO: before v1.09
various testing/oddball versions (like the unofficial XASECO 2.5.2)

As always, most of these are rarely used anymore or have never been used, but old controllers have various bugs in their Dedimania implementation (not to mention the rest of their system :wink: ) and need to be phased out. Eventually, upcoming changes to the Dedimania API which should reduce/eliminate misplaced records, are likely to require all servers to upgrade to the latest versions of their respective controllers.

Re: The big Dedimania discussion

Posted: 29 Jan 2011 19:27
by Xymph
Another small housekeeping update. Below are the tools/versions that are now disabled for Dedimania, with bold indicating the changes since the previous list.

ADEDIMANIA: before v0.7 as well as v0.8(a)
ADEDIMANIA: v0.7 on Aseco v2.1.6 & v2.2.1 and v1.0 on Aseco v2.0b, v2.2a & v3.0.0
ASECO/RASP: all v0.xx
ASECO_CALSMURF2: before v2.2.0c
ASECO_CDV: all
ASECO v1.x: all
ASECO oddball: all
ASRM: before v1.75
CAR: all
DeReCo: before v0.6
FAST: before v3.1.3o in the v3.1.x series, all in the v3.2.0 series, all except v3.2.1u in the v3.2.1 series, all except v3.2.2c/w/y in the v3.2.2 series, and before v3.2.3i in the v3.2.3 series
FeniX: all
FLASH: v"v0.7" (not v0.7)
FlosTruc: 0.1a
FoxControl: all before v0.8.0
ManiaLive: v0.1a, v1685, v1830, v2028 and all before r194
NeSCo: all
Onyx: before v3.1.4
RCP: before v4.0.3.5
RCP: unofficial v1.x
SATO: all
TM-DeReCo: all
TMSC: before v1.00
TMSPS: before v0.3
TRUCK: all in the 9.* series, before 10.12.18 in the 10.* series, and before 11.01.05 in the 11.* series
XASECO: before v1.09
various testing/oddball versions (like the unofficial Fast 0.09beta and XASECO 2.5.2)

As always, most of these are rarely used anymore or have never been used, but old controllers have various bugs in their Dedimania implementation (not to mention the rest of their system :wink: ) and need to be phased out. Eventually, upcoming changes to the Dedimania API which should reduce/eliminate misplaced records, are likely to require all servers to upgrade to the latest versions of their respective controllers.

Edit: changes to the ManiaLive entry, and new FoxControl entry.

Re: The big Dedimania discussion

Posted: 31 May 2011 19:04
by Xymph
High time for another housekeeping update. Below are the tools/versions that are now disabled for Dedimania, with bold indicating the changes since the previous list.

ADEDIMANIA: before v0.7 as well as v0.8(a)
ADEDIMANIA: v0.7 on Aseco v2.1.6 & v2.2.1 and v1.0 on Aseco v2.0b, v2.2a & v3.0.0
ASECO/RASP: all v0.xx
ASECO_CALSMURF2: before v2.2.0c
ASECO_CDV: all
ASECO v1.x: all
ASECO oddball: all
ASRM: before v1.75
CAR: all
DeReCo: before v0.6
FAST: before v3.1.3o in the v3.1.x series, all in the v3.2.0 series, all except v3.2.1u in the v3.2.1 series, all except v3.2.2c/w/y in the v3.2.2 series, and before v3.2.3i as well as v3.2.3j/k/l in the v3.2.3 series
FeniX: all
FLASH: v"v0.7" (not v0.7)
FlosTruc: 0.1a
FoxControl: before v0.8.2
ManiaLive: v0.1a, v1685, v1830, v2028 and all before r214
NeSCo: all
Onyx: before v3.1.4
RCP: before v4.0.3.5
RCP: unofficial v1.x
SATO: all
TM-DeReCo: all
TMSC: before v1.00
TMSPS: before v0.3
TMST: before v1.2
TRUCK: all in the 9.* series, all in the 10.* series, and before 11.02.09 in the 11.* series
XASECO: before v1.10
various testing/oddball versions (like the unofficial Fast 0.09beta and XASECO 2.5.2)

As always, most of these are rarely used anymore or have never been used, but old controllers have various bugs in their Dedimania implementation (not to mention the rest of their system :wink: ) and need to be phased out. Eventually, upcoming changes to the Dedimania API which should reduce/eliminate misplaced records, are likely to require all servers to upgrade to the latest versions of their respective controllers.

Re: The big Dedimania discussion

Posted: 20 Aug 2011 10:12
by Xymph
Here we go with another housekeeping update. Below are the tools/versions that are now disabled for Dedimania, with bold indicating the changes since the previous list.

ADEDIMANIA: before v0.7 as well as v0.8(a) and 0.9a
ADEDIMANIA: v0.7 on Aseco v2.1.6 & v2.2.1 and v1.0 on Aseco v2.0b, v2.2a & v3.0.0
ASECO/RASP: all v0.xx
ASECO_CALSMURF2: before v2.2.0c
ASECO_CDV: all
ASECO v1.x: all
ASECO oddball: all
ASRM: before v1.75
CAR: all
DeReCo: before v0.6
FAST: before v3.1.3o in the v3.1.x series, all in the v3.2.0 series, all except v3.2.1u in the v3.2.1 series, all except v3.2.2c/w/y in the v3.2.2 series, and all except v3.2.3i/j/m/o and before v3.2.3q in the v3.2.3 series
FeniX: all
FLASH: v"v0.7" (not v0.7)
FlosTruc: 0.1a
FoxControl: before v0.9.2
ManiaLive: v0.1a, v1685, v1830, v2028 and all before r267
NeSCo: all
Onyx: before v3.1.4
RCP: before v4.0.3.5
RCP: unofficial v1.x
SATO: all
TM-DeReCo: all
TMSC: before v1.00
TMSPS: before v0.3
TMST: before v1.2
TRUCK: all in the 9.* series, all in the 10.* series, and before 11.02.09 in the 11.* series
XASECO: before v1.11
various testing/oddball versions (like the unofficial Fast 0.09beta and XASECO 2.5.2)

As always, most of these are rarely used anymore or have never been used, but old controllers have various bugs in their Dedimania implementation (not to mention the rest of their system :wink: ) and need to be phased out. Eventually, upcoming changes to the Dedimania API which should reduce/eliminate misplaced records, are likely to require all servers to upgrade to the latest versions of their respective controllers.

Edit: ManiaLive r239 disabled too.

Re: The big Dedimania discussion

Posted: 24 Sep 2012 13:07
by Xymph
A new housekeeping update is quite overdue. Below are the tools/versions that are now disabled for Dedimania, with bold indicating the changes since the previous list.

ADEDIMANIA: before v0.7 as well as v0.8(a) and 0.9a
ADEDIMANIA: v0.7 on Aseco v2.1.6 & v2.2.1 and v1.0 on Aseco v2.0b, v2.2a, v3.0.0 & v4.02
ASECO/RASP: all v0.xx
ASECO_CALSMURF2: before v2.2.0c
ASECO_CDV: all
ASECO v1.x: all
ASECO oddball: all
ASRM: before v1.75
CAR: all
DeReCo: before v0.6
FAST: before v3.1.3o in the v3.1.x series, all in the v3.2.0 series, all except v3.2.1u in the v3.2.1 series, all except v3.2.2c/w/y in the v3.2.2 series, and all except v3.2.3i/j/m and before v3.2.3q in the v3.2.3 series
FeniX: all
FLASH: v"v0.7" (not v0.7)
FlosTruc: 0.1a
FoxControl: before v0.9.2, as well as v4.0
ManiaLive: v0.1a, v1685, v1830, v2028 and all before r267
NeSCo: all
Onyx: before v3.1.4
RCP: before v4.0.3.5
RCP: unofficial v1.x
SATO: all
TM-DeReCo: all
TMGery: v1.0
TMSC: all except v4.02
TMSPS: before v0.3
TMST: before v1.2
TRUCK: all in the 9.* series, all in the 10.* series, and before 11.02.09 in the 11.* series
XASECO: before v1.13
various testing/oddball versions (like the unofficial Fast 0.09beta, TM_GERY 1.0, and XASECO 2.5.2)

Further, below are the tools/versions that are now disabled for Dedimania2 (TM² Canyon):

FAST: before v4.0.0n
XASECO2: before v1.00


As always, most of these are rarely used anymore or have never been used, but old controllers have various bugs in their Dedimania implementation (not to mention the rest of their system :wink: ) and need to be phased out. Eventually, upcoming changes to the Dedimania API which should reduce/eliminate misplaced records, are likely to require all servers to upgrade to the latest versions of their respective controllers.

Re: The big Dedimania discussion

Posted: 28 Jul 2013 16:52
by Xymph
A new housekeeping update is again long overdue. Below are the tools/versions that are now disabled for Dedimania, with bold indicating the changes since the previous list.

ADEDIMANIA, ADEDIMANIA0.7: all
ADEDIMANIA1.0: all except v2.3.0
ASECO/RASP: all v0.xx
ASECO_CALSMURF2: all
ASECO_CALS: all
ASECO_CDV: all
ASECO v1.x: all
ASECO oddball: all
ASRM: before v1.75
CAR: all
DeReCo: before v0.6
FAST: before v3.1.3o in the v3.1.x series, all in the v3.2.0 series, all except v3.2.1u in the v3.2.1 series, all except v3.2.2c/w/y in the v3.2.2 series, and all except v3.2.3i/j/m and before v3.2.3q in the v3.2.3 series
FeniX: all
FLASH: v"v0.7" (not v0.7)
FlosTruc: 0.1a
FoxControl: before v0.9.2, as well as v4.0
ManiaLive: v0.1a, v1685, v1830, v2028 and all before r267
NeSCo: all
Onyx: before v3.1.4
quick: before v0.02beta
RCP: before v4.0.3.5
RCP: unofficial v1.x
SATO: all
TM-DeReCo: all
TMGery: v1.0
TMSC: all except v4.02
TMSPS: before v0.3
TMST: before v1.2
TRUCK: all in the 9.* and 10.* series, and before 11.02.09 in the 11.* series
XASECO: before v1.14
various testing/oddball versions (like the unofficial Fast 0.09beta, TM_GERY 1.0, and XASECO 1.14VX & 2.5.2)

Further, below are the tools/versions that are now disabled for Dedimania2 (TM²):

eXpansion: before v0.11
FAST: before v4.0.0q, and 4.0.0r-ld
FoxControl: before v1.2 Stable
ManiaLive: all
ManiaLive2: before 260-dev
MLconnector: before v0.12
MXController: before v1.0.0.0
XASECO2: before v1.01

As always, most of these are rarely used anymore or have never been used, but old controllers have various bugs in their Dedimania implementation (not to mention the rest of their system :wink: ) and need to be phased out. Eventually, upcoming changes to the Dedimania API which should reduce/eliminate misplaced records, are likely to require all servers to upgrade to the latest versions of their respective controllers.

Re: The big Dedimania discussion

Posted: 31 Oct 2013 13:20
by askuri
Interesting how many Servercontrollers exist o_O

Re: The big Dedimania discussion

Posted: 30 Apr 2014 12:29
by TheM
I'm not sure if I should be in this topic, but it seems with the ManiaPlanet 3 update that the replayvalidation is broken (again):

Code: Select all

[04/30,12:50:15] [Dedimania] Validation replay inconsistent for redextra: skipped 43491 (7558,13328,17901,27045,34228,40580,43491) race: 7 all: 7
[04/30,12:56:48] [Dedimania] Validation replay inconsistent for darkxel: skipped 39948 (9000,14388,21727,27246,33386,39948) race: 6 all: 6
[04/30,13:22:26] [Dedimania] Validation replay inconsistent for sinnernl2: skipped 56390 (11668,20701,28933,56390) race: 4 all: 4
[04/30,13:22:26] [Dedimania] Validation replay inconsistent for zappel: skipped 63427 (12028,22481,32200,63427) race: 4 all: 4
[04/30,13:48:49] [Dedimania] Validation replay inconsistent for sinnernl2: skipped 47158 (7491,14281,23534,33311,36170,45424,47158) race: 7 all: 7
[04/30,13:48:49] [Dedimania] Validation replay inconsistent for zappel: skipped 53068 (8202,16172,26484,38135,41575,51181,53068) race: 7 all: 7
[04/30,13:55:24] [Dedimania] Validation replay inconsistent for scouty: skipped 47012 (17285,25938,34120,39611,47012) race: 5 all: 5
[04/30,14:02:09] [Dedimania] Validation replay inconsistent for scouty: skipped 48228 (6524,11165,19251,25913,29415,31398,38793,43332,48228) race: 9 all: 9
[04/30,14:08:41] [Dedimania] Validation replay inconsistent for scouty: skipped 28904 (5465,9426,16426,19878,25727,28904) race: 6 all: 6
[04/30,14:08:41] [Dedimania] Validation replay inconsistent for sinnernl2: skipped 29338 (5470,9647,16716,20267,26186,29338) race: 6 all: 6
[04/30,14:08:41] [Dedimania] Validation replay inconsistent for zappel: skipped 33915 (5785,10602,20078,24012,30428,33915) race: 6 all: 6
[04/30,14:21:52] [Dedimania] Validation replay inconsistent for redextra: skipped 43688 (22995,29681,43208,43688) race: 4 all: 4
[04/30,14:28:23] [Dedimania] Validation replay inconsistent for redextra: skipped 43625 (23135,29716,43152,43625) race: 4 all: 4
[04/30,14:28:23] [Dedimania] Validation replay inconsistent for scouty: skipped 44598 (23081,30153,44120,44598) race: 4 all: 4
Still using the legacy modes, with the latest version of XAseco2 (1.03).
I suppose there is a problem server-side, with the replay datafetcher or something.

Re: The big Dedimania discussion

Posted: 06 May 2014 17:11
by Rose Tattoo
same here, I got that message too and I guess its only for maps which are from TMNF/TMN, or maps which not exist on MX?!

but I tested it on a mx maps and it also doesnt work, same error message...

I found an information: http://dedimania.net/SITE/forum/viewtop ... 4492#p4492

the fix doesnt work for me,

so we have to wait for an update.

edit,
the quick fix given from Xymph works well, thank you Xymph!!

Re: The big Dedimania discussion

Posted: 13 Feb 2015 17:30
by Xymph
A new housekeeping update is long overdue, as usual. :) Below are the tools/versions that are now disabled for Dedimania, with bold indicating the changes since the previous list.

ADEDIMANIA, ADEDIMANIA0.7: all
ADEDIMANIA1.0: all except v2.3.0
ASECO/RASP: all v0.xx
ASECO_CALSMURF2: all
ASECO_CALS: all
ASECO_CDV: all
ASECO v1.x: all
ASECO oddball: all
ASRM: before v1.75
CAR: all
DeReCo: before v0.6
FAST: all in the v3.1.x series, all in the v3.2.0 series, all in the v3.2.1 series, all except v3.2.2c/y in the v3.2.2 series, and all except v3.2.3j/m/n/q/t in the v3.2.3 series
FeniX: all
FLASH: v"v0.7" (not v0.7)
FlosTruc: 0.1a
FoxControl: before v0.9.2, as well as v4.0
ManiaLive: v0.1a, v1685, v1830, v2028 and all before r267
NeSCo: all
Onyx: before v3.1.4
quick: before v0.02beta
RCP: before v4.0.3.5
RCP: unofficial v1.x
SATO: all
TM-DeReCo: all
TMGery: v1.0
TMSC: all except v4.02
TMSL: before v0.997
TMSPS: before v0.3
TMST: before v1.2
TRUCK: all in the 9.* and 10.* series, and before 11.02.09 in the 11.* series
XASECO: before v1.15b
various testing/oddball versions (like the unofficial Fast 0.09beta, TM_GERY 1.0, and XASECO 1.14VX, 1.15.2, 1.16b, 2 & 2.5.2)

Further, below are the tools/versions that are now disabled for Dedimania2 (TM²):

eXpansion: before v0.9.7 and v0.9.8.0
FAST: before v4.0.0t
FoxControl: before v1.2 Stable
ManiaControl: before v0.15
ManiaLive: all
ManiaLive2: before 260-dev
MLconnector: before v0.15
MXController: before v1.0.0.0
UASECO: before v1.0.0
XASECO2: before v1.02
many testing/oddball/unofficial versions

As always, most of these are rarely used anymore or have never been used, but old controllers have various bugs in their Dedimania implementation (not to mention the rest of their system :wink: ), or do not contain the latest security measures, and thus need to be phased out. Eventually, upcoming changes to the Dedimania API which should reduce/eliminate misplaced records, are likely to require all servers to upgrade to the latest versions of their respective controllers.