The big dedicated server crash identification topic: UPDATED

This is the place where you can find everything related to the dedicated server, control scripts and community tools.

Moderators: Pit Crew, TM-Patrol

User avatar
Dawa
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 21 Apr 2008 18:43
Owned TM-games: TMU, TMN
Contact:

Re: the big dedicated server crash identification topic

Post by Dawa » 10 May 2008 14:16

Server launched till Friday 09/05 3.00pm with the new *.exe after a new crash, no problem so far :)
Member / Admin of the FullSpeedAddicts freaks !

dreamW
wheelbarrow operator
wheelbarrow operator
Posts: 18
Joined: 16 Apr 2008 08:58
Owned TM-games: tmn

Re: the big dedicated server crash identification topic

Post by dreamW » 11 May 2008 14:12

xbx wrote:http://files2.trackmaniaforever.com/Tra ... 7_beta.zip (only contains the executables)

brave ones, please test it a bit, and I'll make a "real" release later.
........................

Server cannot create config files and cache (Default.SystemConfig.Gbx, guestlist.txt, blacklist.txt, Game.FidCache.Gbx)
(before start server, all folders have 777 permission)

Code: Select all

[2008/05/11 17:05:09] Unable to open '/store/gs/TMF/GameData/Config/Default.SystemConfig.Gbx'
after that, folders "GameData" and "Config" losts all permissions....it`s very strange..


system: FreeBSD 6.1 linux_base-fc4

help, plz.

weerwolf1
smooth traffic navigator
smooth traffic navigator
Posts: 236
Joined: 08 May 2008 09:25
Owned TM-games: All but original
Location: The Netherlands

Re: the big dedicated server crash identification topic

Post by weerwolf1 » 12 May 2008 21:36

EDIT: I installed it right away - both server ar up and running for the past 4 hours. Seems to be OK :3 . I'll let you know tomorrow. But still when it was crashing i had 20 -30 players and now there where no more then 10 :roflol:

I stil have problems. The server or servers keep crashing at 2 - 7 hrs. At some point the server running without aseco push up to 14 % CPU. Using aseco would boost the th php procces to a staggering 96%.

I just tried every combination and i cant find the problem.

Someone? PLease any idears?

Weerwolf
LYNX°°°° - Maniaplanet Gaming Community!
news | clan | community | & more
°°°°

giu
sunday driver
sunday driver
Posts: 68
Joined: 30 Apr 2007 09:38
Owned TM-games: tm?
Contact:

Re: the big dedicated server crash identification topic

Post by giu » 15 May 2008 15:17

Crashes regularly or no crash ?
Crashes after a few days running fine. No errors in logfiles. No suspicious behavior of players or scripts.

Windows or linux
Linux SUSE 10.2

Do you run with old config files (2008-04-15 etc)
brandnew everything

Do you start the server with old matchsetting files ?
brandnew everything

Is your server having 60+ users regularly ?
44 max.

Tell a bit about your config, do you autosave replays ?
No

Do you use different than standard upload/download rates etc..
No

Do you or don't you run server scripts ? In case you do:
Xaseco (always newest)
Image

User avatar
BLaHiTiS
lord of the roads
lord of the roads
Posts: 3331
Joined: 12 Aug 2005 15:46
Owned TM-games: tmu tmo tms tmn
Manialink(s): muxitis
Location: Hasselt, Limburg, Belgium
Contact:

Re: the big dedicated server crash identification topic

Post by BLaHiTiS » 15 May 2008 15:25

it's important that you tell which server you are using now , cause theres a beta server..

I didn't have a crash with this one cinse it started on sunday (after i switched from 2008-04-18 to 2008-05-07
Image

  • MB:Asus P8 H61
  • CPU:Intel i5 2400
  • RAM:8 Gb
  • GFX:Asus GTX-580 (1500mb DDR5) - Forceware 75.33
  • DirectX: June 2011
  • SND:Realtek HD on mobo
  • OS:Windows 7 SP1- Home Premium
[/size]

giu
sunday driver
sunday driver
Posts: 68
Joined: 30 Apr 2007 09:38
Owned TM-games: tm?
Contact:

Re: the big dedicated server crash identification topic

Post by giu » 15 May 2008 15:39

2008-04-18 ....sorry forgot....

;)
Image

User avatar
BLaHiTiS
lord of the roads
lord of the roads
Posts: 3331
Joined: 12 Aug 2005 15:46
Owned TM-games: tmu tmo tms tmn
Manialink(s): muxitis
Location: Hasselt, Limburg, Belgium
Contact:

Re: the big dedicated server crash identification topic

Post by BLaHiTiS » 15 May 2008 18:18

so as this is no longer relevant, because there's a new test version: (which I should have put up in the front page agas agao actually), you should test with this one.
Image

  • MB:Asus P8 H61
  • CPU:Intel i5 2400
  • RAM:8 Gb
  • GFX:Asus GTX-580 (1500mb DDR5) - Forceware 75.33
  • DirectX: June 2011
  • SND:Realtek HD on mobo
  • OS:Windows 7 SP1- Home Premium
[/size]

User avatar
Dawa
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 21 Apr 2008 18:43
Owned TM-games: TMU, TMN
Contact:

Re: The big dedicated server crash identification topic: UPDATED

Post by Dawa » 16 May 2008 16:29

Hi all,

Our server is now running for 1 week with the last release (2008-05-07), with an average of 50 people on it all the day.

No crash, no problem at all, it seems that the bug has been fixed, Thx very much to all and to xbx for this new dedicated ;)
Member / Admin of the FullSpeedAddicts freaks !

al2s
pedestrian
pedestrian
Posts: 8
Joined: 30 Sep 2007 07:45
Owned TM-games: TMO, TMN, TMU

Re: The big dedicated server crash identification topic: UPDATED

Post by al2s » 17 May 2008 16:52

switched to the 2008-05-07 Beta-Version ... with option /noautoquit ... let's see

former Version crashed "as usual" after 7 Days ...

weerwolf1
smooth traffic navigator
smooth traffic navigator
Posts: 236
Joined: 08 May 2008 09:25
Owned TM-games: All but original
Location: The Netherlands

Re: The big dedicated server crash identification topic: UPDATED

Post by weerwolf1 » 18 May 2008 20:52

Yeah, ik hate to write this but, my servers are still crashing.
It does not matter if i launch 1 server or 3. It does not matter wich recordsysteem i use. They will crash between 10 min and 5 days. Logs of the server are not showing errors. They simply stop. Aseco let's me see the following entry today:
[05/18,16:20:27] XMLRPC Error [-32700] - transport error - connection interrupted.
(and also all other logs just stop)

I also set up a test server here at home on a win2003 server
This one has a uptime now for 4 days. You can reach it in Netherlands/Gelderland -> Lo30oL

Weerwolf
LYNX°°°° - Maniaplanet Gaming Community!
news | clan | community | & more
°°°°

al2s
pedestrian
pedestrian
Posts: 8
Joined: 30 Sep 2007 07:45
Owned TM-games: TMO, TMN, TMU

Re: The big dedicated server crash identification topic: UPDATED

Post by al2s » 19 May 2008 21:43

al2s wrote:switched to the 2008-05-07 Beta-Version ... with option /noautoquit ... let's see

former Version crashed "as usual" after 7 Days ...
2 days and a crash ... no hints in the logs or else :ftw:

eekcage
cyclist
cyclist
Posts: 41
Joined: 19 Apr 2008 13:52
Owned TM-games: TMUF

Re: The big dedicated server crash identification topic: UPDATED

Post by eekcage » 20 May 2008 16:48

Heya

I run the SAW servers, I'm going to load the beta after the old crashes. should be a few hours

Will let you know how it goes. Max uptime has been a day so far.

eek/nico

UltraLoW
pedestrian
pedestrian
Posts: 6
Joined: 18 Apr 2008 18:12
Owned TM-games: TMS TMU

Re: The big dedicated server crash identification topic: UPDATED

Post by UltraLoW » 24 May 2008 10:11

Where i can download this new files? Link is broken for me! :(

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: The big dedicated server crash identification topic: UPDATED

Post by oliverde8 » 24 May 2008 12:41

ecause the new realese is newer then this beta. just look at the main post :thumbsup:
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

User avatar
Mat-d-Rat
cyclist
cyclist
Posts: 37
Joined: 01 Nov 2007 20:53
Owned TM-games: TMN, TMU, TMF

Re: The big dedicated server crash identification topic: UPDATED

Post by Mat-d-Rat » 03 Jun 2008 15:42

Just noticed this thread, and I have the same issue even with latest Server software. Just crashes/no log no reason etc.

Processor #1 Vendor: GenuineIntel
Processor #1 Name: Intel(R) Pentium(R) 4 CPU 2.66GHz
Processor #1 speed: 2662.116 MHz
Processor #1 cache size: 1024 KB

Memory: 2065968k/2088640k available (2588k kernel code, 21492k reserved, 1137k data, 244k init, 1171136k highmem)

Dedicated server with 100mbit connection running a few websites and 2 tmnf servers. Normally 1-32 players on it, seems to crash at anytime.

Post Reply