Dedicated server for TMO/TMS/TMN : final release

This is the place where you can find everything related to the dedicated server, control scripts and community tools.

Moderators: Pit Crew, TM-Patrol

spk800marcel
highway camper
highway camper
Posts: 4
Joined: 10 Mar 2007 15:01
Contact:

I´ve got a Problem !!

Post by spk800marcel » 11 Mar 2007 09:48

My Server show all Players withe Invalid Times and map is over .
What Can it Be ??
I have the Dedicated Server files and a Windows Root Server !!
Plz Help Me !!!

User avatar
TrabTowN
Pit Crew
Pit Crew
Posts: 789
Joined: 03 Nov 2005 14:30
Owned TM-games: TMS,tmn,TMU
Location: Ireland/orginal SACHSE^^
Contact:

Post by TrabTowN » 11 Mar 2007 10:21

try the following...
- open taskmanager
- go to the "Processes" tab
- right click on the server app
- set priority to "Above Normal"

that fixed the invalid time issue for us....
100²% addicted
Image
Image

eyez
Pit Crew
Pit Crew
Posts: 379
Joined: 15 Mar 2006 17:46
Location: Aberdeen, UK
Contact:

Re: I´ve got a Problem !!

Post by eyez » 11 Mar 2007 10:29

spk800marcel wrote:My Server show all Players withe Invalid Times and map is over .
What Can it Be ??
I have the Dedicated Server files and a Windows Root Server !!
Plz Help Me !!!
If its running on dual core, do the same as trab suggested except go to 'set affinity' and deselect all but one core. ;)
AMD X2 3800+
1gb Dual-channel RAM (2x512 kingston DDR400)
PowerColor Radeon x700 256mb GFX
SoundBlaster Audigy 2 ZS Platinum Pro

spk800marcel
highway camper
highway camper
Posts: 4
Joined: 10 Mar 2007 15:01
Contact:

THX a lot

Post by spk800marcel » 11 Mar 2007 12:39

try the following...
- open taskmanager
- go to the "Processes" tab
- right click on the server app
- set priority to "Above Normal"

that fixed the invalid time issue for us....

And i have disable One CPU ,we have Dual Core !!


THX M8 s !!

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Re: I´ve got a Problem !!

Post by Slig » 11 Mar 2007 13:19

eyez wrote:If its running on dual core, do the same as trab suggested except go to 'set affinity' and deselect all but one core. ;)
i added the info in first post :D

same for TMU dedicated ?

User avatar
TrabTowN
Pit Crew
Pit Crew
Posts: 789
Joined: 03 Nov 2005 14:30
Owned TM-games: TMS,tmn,TMU
Location: Ireland/orginal SACHSE^^
Contact:

Re: I´ve got a Problem !!

Post by TrabTowN » 11 Mar 2007 23:18

Slig wrote: same for TMU dedicated ?
in tmu its not as bad as in tms/tmn ... but sometimes we made the expirience, if the server was bussy and sql+apache was doing its job, that the server got some "invalide time messages"... so for a windows maschine its no harm to set it to "Above normal"... the servers run defenetly more stable...
100²% addicted
Image
Image

dadu
wheelbarrow operator
wheelbarrow operator
Posts: 20
Joined: 12 Mar 2007 10:53
Contact:

Post by dadu » 15 Mar 2007 15:27

Hello, i've installed this version of dedicated server plus the last version of aseco..
it's all ok, all players can join my game without any lag. the problem is that suddently my server disconnect all players, and it result not connected for 1-2 minutes... often it happens when there are a lot of player (19-15 maximum), but, i have no lag, NEVER, it only disconnect !!!
my game is TMN.. Please, help meeeee!!

User avatar
BReMFoX
smooth traffic navigator
smooth traffic navigator
Posts: 275
Joined: 05 Sep 2006 08:53
Owned TM-games: TMUF
Location: The Netherlands

Post by BReMFoX » 15 Mar 2007 18:49

If you have a router, check if it's still working fine....
I had the same problem....
Kicking all players after a while, because the router couldn't handle it or something...

dadu
wheelbarrow operator
wheelbarrow operator
Posts: 20
Joined: 12 Mar 2007 10:53
Contact:

Post by dadu » 15 Mar 2007 19:32

It seems that when it arrives at the end of the playlist, it kick all the players.. it is possible???

User avatar
BReMFoX
smooth traffic navigator
smooth traffic navigator
Posts: 275
Joined: 05 Sep 2006 08:53
Owned TM-games: TMUF
Location: The Netherlands

Post by BReMFoX » 15 Mar 2007 20:22

Ah, it's the track....
Also had this problem, it may be a corrupt track orso...
Check when the server kicks people.
Then delete that track (the one it switches to).

dadu
wheelbarrow operator
wheelbarrow operator
Posts: 20
Joined: 12 Mar 2007 10:53
Contact:

Post by dadu » 15 Mar 2007 21:04

YEAAAHHH!! it was the track... thanks a lot!!!!!!!!!!!!!!!!!!!!!!!!

User avatar
Fisch.666
happy cruiser
happy cruiser
Posts: 136
Joined: 18 May 2006 01:13
Owned TM-games: TMU, TMN, TMUF, TMNF
Location: Germany
Contact:

Post by Fisch.666 » 26 Mar 2007 11:59

Hi!

I hope this wasn't posted before. Are there any chances to deactivate the kick and banvotes? I ask this because in the last few days 2 people were banned from my server with an ban vote... :(

Funnyman
speedy pilot
speedy pilot
Posts: 328
Joined: 31 Mar 2006 06:08
Owned TM-games: TMS, TMU, TMF
Location: Netherlands
Contact:

Post by Funnyman » 26 Mar 2007 14:27

Fisch.666 wrote:Hi!

I hope this wasn't posted before. Are there any chances to deactivate the kick and banvotes? I ask this because in the last few days 2 people were banned from my server with an ban vote... :(
As far as i know u can disable voting by setting vote rate to 1.0 but this cancels all voting also next map and restart map
There is also a command for this in rasp wich cancels a voting round but can only be done by one of the server admins
command = /admin cancel
Ð Ξ F u n n y M a n
Image

User avatar
Fisch.666
happy cruiser
happy cruiser
Posts: 136
Joined: 18 May 2006 01:13
Owned TM-games: TMU, TMN, TMUF, TMNF
Location: Germany
Contact:

Post by Fisch.666 » 26 Mar 2007 18:14

Mhhh, ok. Thanks for the info.

Maybe i set the vote ratio to 0.9, hope this stops the user from banning other users on my server.

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Post by Slig » 29 Mar 2007 12:22

to fully disable the votes, the real way is setting the votetime to 0

Post Reply