Please Help I've been stuck for days!!!

This is the forum for ServerMania which is a graphical dedicated server controller software written in .NET framework.

Moderators: Cyrlaur, TM-Patrol

Post Reply
TheCrow
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 10 Aug 2009 23:31
Owned TM-games: TMUF

Please Help I've been stuck for days!!!

Post by TheCrow » 10 Aug 2009 23:43

Basically i'm trying to make my own dedicated server using ServerMania.

Everything is good and i have the right account for a server.

The only problem i have is match settings. I have gone into the game and made a server that way and saves the settings. (i think this is how you do it), however when i try to load them into server mania it says ....

Image

Now i've tried copying the match settings from c:\documents\trackmania\tracks\matchsettings and putting them into c:\gamedata\tracks but i still get the same error as above.

I've tried following all the tutorials but to be honest i cant get my head around this match settings problem.

Any help people could offer would be most appreciated.

TheCrow
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 10 Aug 2009 23:31
Owned TM-games: TMUF

Re: Please Help I've been stuck for days!!!

Post by TheCrow » 11 Aug 2009 04:29

Wow ten views and no reply?

jouko100
speedy pilot
speedy pilot
Posts: 375
Joined: 10 Mar 2007 09:33
Location: finland

Re: Please Help I've been stuck for days!!!

Post by jouko100 » 11 Aug 2009 05:16

try

C:\dedicated folder\GameData\Tracks\MatchSettings\tracklist.txt

TheCrow
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 10 Aug 2009 23:31
Owned TM-games: TMUF

Re: Please Help I've been stuck for days!!!

Post by TheCrow » 11 Aug 2009 06:32

Still exactly the same problem.

The thing is really stressing me out as i've tried locations all over the place and still can't get it to work.

User avatar
lille79
Pit Crew
Pit Crew
Posts: 881
Joined: 09 Dec 2007 15:04
Owned TM-games: TMN, TMNF, TMUF
Location: Norway
Contact:

Re: Please Help I've been stuck for days!!!

Post by lille79 » 11 Aug 2009 06:41

First of all you have to find out what file Servermania looks for. I haven't used it, but somewhere it should say which matchsettings-file you want to use. Why don't you try the default matchsettings-file to get started. c:\dedicatedserverfolder\gamedata\tracks\matchsettings\nations\NationsBlue.txt

The location in the startup-script (which I guess is created by ServerMania) need to match the place you put the matchsettings-file.
/lille79
Old man of the Norwegian Trackmania team Super Sheep Racing
To visit my homepage/blog, and download the usbTMFserver, this is the place to go.

fordry
speedy pilot
speedy pilot
Posts: 368
Joined: 24 Jan 2008 20:53
Owned TM-games: TMUF TMN
Contact:

Re: Please Help I've been stuck for days!!!

Post by fordry » 12 Aug 2009 19:15

ya, matchsettings files will never go in the trackmania folder in "my documents" needs to be within the server files folder, wherever you have that located. (well, if you changed the config to locate matchsettings files there, you could, but by default the server looks for the matchsettings in its own folder and there isn't a good reason i can think of to put it anywhere else.)

Post Reply