[A2.x.x/Rasp Extended Jukebox Oliverde8

This forum is dedicated to the Aseco/Rasp 2 server records and control script by Flo and Assembler Maniac. Announcements and issues can be discussed in this forum.

Moderators: Flo, Assembler Maniac, f*ckfish, TM-Patrol

User avatar
Jackel
speedy pilot
speedy pilot
Posts: 316
Joined: 06 Oct 2006 09:57
Owned TM-games: TMN,TMU,&TMS
Location: Florida, USA
Contact:

Re: [A2.x.x/Rasp_Jukebox] Oliverde8 V1.0 BEtA2

Post by Jackel » 12 Dec 2008 23:45

uploaded latest version and getting this error when I use the /list command

Code: Select all

[12/12,18:47:42] player unrtjackel used chat command '/list '
[Aseco] UpdateFramework - SendDisplayManialinkPageToLogin Failed - [-1000] Inval
id Manialink page: Error reading Attributes.
        login/xml written to xml-failure.txt
[12/12,18:47:42] XMLRPC Error [-1000] - Invalid Manialink page: Error reading At
tributes.
[Aseco] UpdateFramework - SendDisplayManialinkPageToLogin Failed - [-1000] Inval
id Manialink page: Error reading Attributes.
        login/xml written to xml-failure.txt
[12/12,18:47:51] XMLRPC Error [-1000] - Invalid Manialink page: Error reading At
tributes.
[Aseco] UpdateFramework - SendDisplayManialinkPageToLogin Failed - [-1000] Inval
id Manialink page: Error reading Attributes.
        login/xml written to xml-failure.txt
[12/12,18:48:16] XMLRPC Error [-1000] - Invalid Manialink page: Error reading At
tributes.
Founder and Admin of Cobra Gaming Systems.

Image
Image
Image

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: [A2.x.x/Rasp_Jukebox] Oliverde8 V1.0 BEtA2

Post by oliverde8 » 13 Dec 2008 07:59

did you add the JB_style.xml?
it should be in \plugins\rasp\Manialink

and the jb.xml file was also modified did you modified it ?
you will find the modified version in newinstall folder
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

User avatar
Jackel
speedy pilot
speedy pilot
Posts: 316
Joined: 06 Oct 2006 09:57
Owned TM-games: TMN,TMU,&TMS
Location: Florida, USA
Contact:

Re: [A2.x.x/Rasp_Jukebox] Oliverde8 V1.0 BEtA2

Post by Jackel » 13 Dec 2008 11:16

added new Jb.xml too aseco root. and as for the JB_Style.xml it was installed too the manialink folder inside RASP folder, should that one go somewhere else. I let WinRar install it too it's default location.
Founder and Admin of Cobra Gaming Systems.

Image
Image
Image

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: [A2.x.x/Rasp_Jukebox] Oliverde8 V1.0 BEtA2

Post by oliverde8 » 13 Dec 2008 11:22

Jackel wrote:added new Jb.xml too aseco root. and as for the JB_Style.xml it was installed too the manialink folder inside RASP folder, should that one go somewhere else. I let WinRar install it too it's default location.
Yes winrar location is correct :thumbsup:
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

User avatar
Jackel
speedy pilot
speedy pilot
Posts: 316
Joined: 06 Oct 2006 09:57
Owned TM-games: TMN,TMU,&TMS
Location: Florida, USA
Contact:

Re: [A2.x.x/Rasp_Jukebox] Oliverde8 V1.0 BEtA2

Post by Jackel » 14 Dec 2008 01:07

guess I'll test it out on the my Island server figure out what went wrong then. it's not as busy as my Stadium server
Founder and Admin of Cobra Gaming Systems.

Image
Image
Image

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by oliverde8 » 16 Dec 2008 16:42

still problems or is it working ?
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

User avatar
Jackel
speedy pilot
speedy pilot
Posts: 316
Joined: 06 Oct 2006 09:57
Owned TM-games: TMN,TMU,&TMS
Location: Florida, USA
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by Jackel » 17 Dec 2008 00:22

haven't had time too test more, will try this weekend.
Founder and Admin of Cobra Gaming Systems.

Image
Image
Image

User avatar
Jackel
speedy pilot
speedy pilot
Posts: 316
Joined: 06 Oct 2006 09:57
Owned TM-games: TMN,TMU,&TMS
Location: Florida, USA
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by Jackel » 21 Dec 2008 02:02

ok, got too test it more with my Island server, and I'm getting same errors as before, using just the basic /list command. but if I tried /list with an author name or track name it returned the tracklist window with no errors. of course when I tested it with my login as the paramenter for /list it showed a blank window instead of saying no tracks found.
Founder and Admin of Cobra Gaming Systems.

Image
Image
Image

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by oliverde8 » 21 Dec 2008 09:19

Jackel wrote:ok, got too test it more with my Island server, and I'm getting same errors as before, using just the basic /list command. but if I tried /list with an author name or track name it returned the tracklist window with no errors. of course when I tested it with my login as the paramenter for /list it showed a blank window instead of saying no tracks found.
very strange :? sometimes it doesen't show the message with me also but in other cases it works. I will look for it as soon as possible
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by oliverde8 » 24 Dec 2008 13:31

Jackel I am unable to create the same error, :(

which version of php do you use? is there any error message on Aseco startup?


Can you delete your xml-failure file in Aseco main directory and call /list after just copy me the contenent in xml-failure that will be recreated. I will se if I can find from the XML probleme the one on my code
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

User avatar
Jackel
speedy pilot
speedy pilot
Posts: 316
Joined: 06 Oct 2006 09:57
Owned TM-games: TMN,TMU,&TMS
Location: Florida, USA
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by Jackel » 24 Dec 2008 15:00

php version is 5.2.6

here is my xml-failure filehttp://jackel.homedns.org/xml-failure.txt

and there is one error on aseco start-up, but it's in Fufi Widgets but aseco still starts up ok.

Code: Select all

[PHP Warning] Invalid argument supplied for foreach() on line 631 in file C:\Ase
co220c Island\plugins\plugin.fufi.widgets.php
and the widgets are version .8b
Founder and Admin of Cobra Gaming Systems.

Image
Image
Image

Assembler Maniac
Pit Crew
Pit Crew
Posts: 1493
Joined: 03 Jun 2006 13:24
Owned TM-games: TMU
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by Assembler Maniac » 24 Dec 2008 15:24

From the bottom of the file, look backwards for a blank line. The one above that has quotes (") in the "text" field. It looks like TMF server doesn't know how to interpret data when it has quote marks in it. (which really isn't too suprising as the " is the delimiter for content)

edit:
I've confirmed that the last player on the page (ends in "ion") is the problem.

The extra quotes are causing the TMF server parser to barf. It can't find any more data because there's an odd number of quotes and it leaves a string open so the parser never finds the end of the XML block.

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by oliverde8 » 25 Dec 2008 08:55

^^Thanks a lot Assembler Maniac :thumbsup: I would have passed a day not seing that.

I should take of " from names then will it work if I replace it with a \" I will have a try after christmas
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

Assembler Maniac
Pit Crew
Pit Crew
Posts: 1493
Joined: 03 Jun 2006 13:24
Owned TM-games: TMU
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by Assembler Maniac » 25 Dec 2008 12:50

I'd think replacing it with " would be more appropriate. It's XML not the php code (where a \" would be needed) that's causing the problem.

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: [A2.x.x/Rasp Extended Jukebox Oliverde8

Post by oliverde8 » 27 Dec 2008 09:29

Assembler Maniac wrote:I'd think replacing it with " would be more appropriate. It's XML not the php code (where a \" would be needed) that's causing the problem.
of course. what was I telling before

Updated version 1.1 it works if names have " :)
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

Post Reply