[(X)Aseco/FAST] AutoQueue v0.60b

This forum is dedicated to the Aseco/Rasp 2 server records and control script by Flo and Assembler Maniac. Announcements and issues can be discussed in this forum.

Moderators: Flo, Assembler Maniac, f*ckfish, TM-Patrol

User avatar
f*ckfish
Pit Crew
Pit Crew
Posts: 1302
Joined: 15 Jun 2007 07:59
Owned TM-games: TMNF, TMUF
Location: Dresden, Germany
Contact:

Re: [(X)Aseco/FAST] AutoQueue v0.60b

Post by f*ckfish » 16 Feb 2009 21:05

The list does not display in 0.60 because I forgot to comment out a debug line.
A fixed version 0.60b is now available for download.
inactive, sorry

User avatar
J-S
happy cruiser
happy cruiser
Posts: 149
Joined: 24 Apr 2008 18:20
Owned TM-games: TMN,TMUF,TMO,TMS
Manialink(s): shark
Location: Grenoble - France
Contact:

Re: [(X)Aseco/FAST] AutoQueue v0.60b

Post by J-S » 22 Feb 2009 20:36

hi f*ckfish !!!

First, thanks for your plugins which help me to manage players on my server. :thumbsup:

I installed your new version 0.60b and i've got few problem with special characters like "

See the results on aseco log :
[RPC Error -1000] Invalid Manialink page: Error reading Attributes.
Array
(
[0] => SendDisplayManialinkPageToLogin
[1] => Array
(
[0] => ******
[1] => <?xml version="1.0" encoding="UTF-8"?><manialinks><manialink id ="3842000"><frame posn="12 -34.3 10" scale="0.77"><quad sizen="1.5 1.5" halign="center" valign="center" posn="11.5 -1.5 0.003" style="Icons64x64_1" substyle="Close" action="3842001"/><format textsize="1"/><quad posn="0 0 0.001" sizen="13 17" style="Bgs1" substyle="BgTitle3"/><label posn="1 -0.5 0.002" sizen="10 2" text="$oQueue"/><quad posn="0.5 -2.5 0.002" sizen="2 1.8" style="BgsPlayerCard" substyle="BgCardSystem"/><quad posn="2.7 -2.5 0.002" sizen="9.8 1.8" style="BgsPlayerCard" substyle="BgCardSystem"/><label posn="2.2 -2.65 0.003" halign="right" text="1"/><label sizen="9 2" posn="3 -2.65 0.003" text="$010(Troopo) $0ff " J A n O t 9 2 ""/><quad posn="0.5 -4.5 0.002" sizen="12 12" style="BgsPlayerCard" substyle="BgCardSystem"/></frame></manialink></manialinks>
[2] => 0
[3] =>
)

)

i've got this when a player have a number login :
[RPC Error -501] Value of type INT supplied where type STRING was expected.
Array
(
[0] => SendDisplayManialinkPageToLogin
[1] => Array
(
[0] => 1208243
[1] => <?xml version="1.0" encoding="UTF-8"?><manialinks><manialink id ="3842000"><frame posn="12 -34.3 10" scale="0.77"><quad sizen="1.5 1.5" halign="center" valign="center" posn="11.5 -1.5 0.003" style="Icons64x64_1" substyle="Close" action="3842001"/><format textsize="1"/><quad posn="0 0 0.001" sizen="13 17" style="Bgs1" substyle="BgTitle3"/><label posn="1 -0.5 0.002" sizen="10 2" text="$oQueue"/><quad posn="0.5 -2.5 0.002" sizen="2 1.8" style="BgsPlayerCard" substyle="BgCardSystem"/><quad posn="2.7 -2.5 0.002" sizen="9.8 1.8" style="BgsPlayerCard" substyle="BgCardSystem"/><label posn="2.2 -2.65 0.003" halign="right" text="1"/><label sizen="9 2" posn="3 -2.65 0.003" text="stan"/><quad posn="0.5 -4.5 0.002" sizen="12 12" style="BgsPlayerCard" substyle="BgCardSystem"/></frame></manialink></manialinks>
[2] => 0
[3] =>
)

)
I've got other error (login unknown). Is it possible to disable debug feature of Autoqueue plugin ? Because i've got a lot of RPC error in my log.

Thanks for your assistance


EDIT : Another thing, this morning my aseco crash because memory limit exceed. When i restarted it, the plugin created an infinite loop with a lot of RPC-error. All players on my server passed on spectator mode without the opportunity to switch in player mode. I've forgotten to save the log file but the next time. I'll send you the log to check where is the problem

User avatar
f*ckfish
Pit Crew
Pit Crew
Posts: 1302
Joined: 15 Jun 2007 07:59
Owned TM-games: TMNF, TMUF
Location: Dresden, Germany
Contact:

Re: [(X)Aseco/FAST] AutoQueue v0.60b

Post by f*ckfish » 24 Feb 2009 03:17

There are players with numbers as logins? Weird... I'll have a look at it. Also at the other issue. Thanks for the info =)
inactive, sorry

schmidi
smooth traffic navigator
smooth traffic navigator
Posts: 196
Joined: 15 Jul 2008 22:25
Owned TM-games: tmo, tms, tmuf

Re: [(X)Aseco/FAST] AutoQueue v0.60b

Post by schmidi » 04 Jun 2009 21:12

did some updates/fixes.
fufi autoqueue v0.70a

Post Reply